<html><head><style> body {height: 100%; color:#000000; font-size:12pt; font-family:Arial;}</style></head><body>Hi,<br><br>It looks like around Fedora 15, several changes were made to administrative<br>configurations...lots of /etc/ changes. One change was to use the bios naming<br>to produce network interface names like "em1" instead of "eth0", others were<br>changes in CUPS file layout.<br><br>For the ethernet side, I don't mind using em1 versus eth0, though I see it has<br>caused a number of people to have to rewrite scripts. However, I need to create<br>a static alias for non-public internal networking, and although there are web<br>pages which show aliases/second-IP should work via something similar to<br>this in /etc/sysconfig/network-scripts/ifcfg-em1:0, the scripting is completely<br>ignored:<br><br><CODE SNIPPET><br>   IPADDR="192.168.1.2"<br>   NETMASK="255.255.255.0"<br>   NETWORK="192.168.1.0"<br>   BROADCAST="192.168.1.255"<br>   BOOTPROTO="static"<br>   DEVICE="em1:0"<br>   TYPE="Ethernet"<br>   ONBOOT="yes"<br></CODE SNIPPET><br>(OT: Wish I had a patent on the word "snippet"...or better yet, a copyright<br>on bugs...I'd sure be rich...let the guy with ownership of "1" and "0" be<br>jealous :P )<br><br>Even with proper permissions, and network restart, no alias ever shows<br>up. If I specifically use ifconfig on any alias name, whether it has a script<br>or not, e.g., "ifconfig em1:25", it shows up without error, but unconfigured,<br>like this:<br><br>em1:0     Link encap:Ethernet  HWaddr aa:bb:cc:dd:ee:ff  <br>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1<br>          Interrupt:41 Base address:0x8000 <br>...HWaddr edited, but it is the valid MAC in the real output.<br><br>Does anyone here know why Fedora 16 ignores a valid alias file? This<br>install is a fairly normal installation for a developer, and kept up to date.<br><br>Thanks!<br><br>D. Stimits, stimits AT comcast DOT net<br></body></html>